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General

To utilise time reporting only makes sense, if it covers the entire team and all its
activities. As time reporting provides important information for the assessment of your
projects, the standard mpp format of Microsoft Project is not suitable, since it can
only contain one project. Time reporting using Afinion Project-Viewer, therefore,
requires a database which contains all projects, for which time shall be reported.
Several databases may be used for different departments, yet consolidation of the
data will then be more difficult.

Databases supported by Afinion Project-Viewer are:

mdb/mpd, the Microsoft Access database or the Microsoft Project database
(actually the same with a different extension)

Microsoft SQL Server and the related Microsoft Project Server

Other databases, especially Oracle, would be possible. These are however bound to
certain conditions by Microsoft Project. Please contact us, if you are interested.

Resource names can be selected arbitrarily. Decisive for the time reporting is the
entry of the Windows user account in the corresponding field in Microsoft Project. For
additional information see Chapter 2.3 below.

Time reporting with Afinion Project-Viewer does not require an extensive installation.

By extracting the program files into a local folder everything is prepared and can be
utilised by the project team members immediately, provided the project data have

been saved in a database and the Windows user account has been entered for all

resources.

In principle tfime reporting can be used as a front end for SAP or other ERP systems. To
fransfer the data correctly however requires some additional steps, that have to be
determined in a definition process. Since Microsoft Project does not contain any
security elements in this context, these have to be provided by the Afinion Project-
Viewer. Please contact us, if you are interested.

Afinion Project-Viewer Time Reporting is compatible with all versions of Microsoft
Project 2000 and later. The support of Project 98 is not foreseen, since this version is
not supported by Microsoft itself any more.

First Steps

Basic Decisions

Once you have decided to introduce time reporting using Afinion Project-Viewer
some basic decisions have to be made. Please take your time for this, since the
quality of your data will depend significantly on the prerequisites made here. The
required steps are described below.

Expand Timephased Data in Microsoft Project

In order to make the data transparent for Microsoft Project and to link them with the

activities, in Microsoft Project go to menu Tools > Options, Register Save and activate
“Expand timephased data in the database”. Press “Set as Default” in order to set this
option automatically for every new project. This option has to be set before entering

any time reporting data.
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Expand timephased data in the database:

Set as Default
Help O, | Cancel |

Entering Windows Users in Microsoft Project
Open Microsoft Project and select the Resource Sheet.

Insert column “Windows User Account” unless a different field has been assigned
(see Chapter 2.4, Selection 4)

For domain users enter “Domain\Login”, i.e. “MyCompany\MyLogin"”, for users
belonging to a workgroup or with standalone pc's enter “PC-Name\Login”, i.e.
“MyPC\MyLogin".

i ] Resource Matme Windowws Uzer Accourt | Type hdat
1 Endineer Wik
Dormain Tester Domain'Login Work
Wiarkgroup Tester PC-Mamellogin Work

Field Mapping

Before setting up field allocations, you have to connect the Afinion Project-Viewer
with a database. Either create a new, empty project in Microsoft Project and save it
in a database or else, if you use Project Server, configure it directly. Time reporting in
the Afinion Project-Viewer is completely independent of Microsoft settings. You
cannot modify any Web Access data. Note however that the fields you want to use
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for fime reporting have not been pre-assigned by the project manager. Normally
these fields will be free. If not, assign different fields as described below.

Open Afinion Project-Viewer

Go to menu Admin > Time reporting
- Enter the password (default password is “Apv1!” without quotation marks)
« Select the fields to be used for time reporting in Microsoft Project

7 Ty
[=] Time Repoting Properties
Field mappings
Every resource can wrike [Flagl? v]
locked For time reporting [Flaglﬁ v]
Yacomplete [Numl:uerl? v]

YWindows Login [Winduws Iser Account v]

S'ork [Baseline Work 7 v]

[ Save ] [ Cancel

These settings have the following properties:

Selection 1:
Default:
Properties:

Alternative Fields:

Selection 2:
Default:
Properties:

Alternative Fields:

Selection 3:
Default:
Properties:

Every resource can write

Flag17

If the project manager sefts this field to *no” or empty (default),
only the resources assigned to an activity may report work
hours to this activity. This setting corresponds to the Microsoft
sefting in Web Access.

If you have projects where the members should be able to
report work hours quickly and instantly to any or selected
activities, set this flag to yes. To set the flag for all activities insert
the column in a Microsoft Project table, set the value for the first
activity to “yes” and then activate the entire column and
select “Fill down” from the Edit menu. Now every resource in
the resource table may report work hours to these activities.
Flag 1 — 20, Enterprise Flag 1 — 20 (Enterprise fields are only
available when using Project Server)

Locked for time reporting

Flog16

If this field is set to “no” or is left empty (default), every resource
may report work hours to the corresponding activity. If it is set to
“yes”, nobody - including assigned resources — may report work
hours. This feature is useful, when external resources, which do
not have access to the fime reporting, are assigned to an
activity and when an activity is completed and no further hours
shall be booked. This also prevents belated bookings.

Flag 1 — 20, Enterprise Flag 1 — 20 (Enterprise fields are only
available when using Project Server)

%»complete
Numberl7
Every project member can estimate his progress himself and
enter it in the fime reporting. The program then calculates a



Alternative Fields:

Selection 4:
Default:
Properties:

Alternative Fields:

Important:

Selection 5:
Default:
Properties:

Alternative Fields:

Important:
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total progress based on the %complete entered by the
individual members and the total number of hours planned by
the project manager.

Example 1: Resource A has been assigned 10 h, resource B has
been assigned 10 h. Resource A reports 40%, resource B reports
60%. Afinion Project-Viewer now calculates 50% for the activity.
Example 2: Resource A has been assigned 10 h, resource B has
been assigned 30 h. Resource A reports 5 h and 50%, resource B
reports 10 h and 33%. Afinion Project-Viewer now calculates
37.5% for the activity.

Number 1 — 20, Enterprise Number 1 — 40 (Enterprise fields are
only available when using Project Server)

Windows Login

Windows User Account

Defines which field is being used to link Afinion Project-Viewer
with Microsoft Project resources.

Code, Text 1 - 20, Enterprise Text 1 — 40 (Enterprise fields are only
available when using Project Server)

Should you use a different field, i.e. Text1, please note that this is
the Text1 field of the resource and not of the activity. To enter
the user account you still first have to switch to the resource
sheet and insert column Text 1 there.

Work

Baseline Work 7

Field for consolidated work hours

Baseline Work 1 - 10, Number 1 - 20

The Baseline Work fields are used by Microsoft Project to store
baselines. We therefore do not recommend using Baseline Work
1-5.

The Baseline Work 1 — 20 fields do not exist in Microsoft Project
2000. Use Number16 instead!



Using Time Reporting

Data Entry
Start Afinion Project-Viewer

Go to menu File > Connection Manager

i Marne | Type | Description
‘Wizard :
PP Jdatabase|Testprojekt deutsch.mpp
PP .idatabase|Testproject english.mpp
MS Access DeAPMLINEDATADacumentation_Afiniont APY 3\ Afinion. mpd

PP ' M5 Access \MSSQL SErver ".LDSN ‘.ls.qp \Production Planning \

Name File: Mame
| | [PMLINEDAT A\ Documentation_afinion\aPyaAafinion.mpd || ... |

[ T ] [ Delete l [ Conneck J

rFY

To open a new project press New, select the MS Access or the MSSQL Server register
(as appropriate) and browse for the project database, press Save, then press
Connect.

Project | M5 Project Version Resource |
-Task Project |2000/2002 Domain Tester
Zeiterfassung 2000/2002 Enginesr
€14
WH
‘Workgroup Tester
’ Load ] ’ DE Connection ] ’ Close ]

Now select a project and a resource (blank line = all resources) from the list and press
Load.

To open an existing project, go to menu File > Load Project to open above form
directly. Remember: Only MS Access and MSSQL Server project databases may be
used for time reporting.
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To report work hours for an activity, double-click on the task. The following window
opens:

7 1
=] Time reporting
I
KM S0 Mo 05, 12,05 0i 06,1205 MiO7. 12,05 Do05,12.05 Fr09,12.05 53 10.12.05 S0 11.12.05 Facomplete
ey 2.5 3 4.5 e 15|
[ Cancel ” Save ]

Enter the daily work hours in the fields between the <<< and >>> buttons.
Enter your completion estimate in percent in the field “%complete”.

Press Save.

Note: If the above window does not open by double-clicking the task, this may be
due to:

* Yourlogin in the field “Window User Account” is missing or wrong.

» The project manager only allows assigned resources and you are not assigned
to the selected activity.

» The project manager has blocked the activity.

View Progress in Microsoft Project

The sample project “Afinion.mpd"” available from

http://pmline.co.uk/en/downloads contains the sample view “*Time Report”
showing both the standard progress (black bar) and the progress reported in the
Afinion Project-Viewer (red bar). The report uses the table “*Time Report”. The sample
has been set up using Microsoft Project 2000, i.e. the work hours reported are stored
in field “Number16”.

Task Mame Duration Planned Work | ActuslWork Hours | Critical Work % Complete % Wyork Progress | Critical Devistion | Resource Mames
1 Sample Task 1w 40h 13h ¥ 30% 25% Enginesr
2 Your Task 1 40h Oh ¥ 0% 0% 4 Domain Tester

The table of this report uses the following custom fields:
Actual Work Hours (Text16) Formula: [Number14] & " h"

Critical Work (Number15) Formula: [Work]-[Number16]
Graphical Indicators:


http://pmline.co.uk/en/downloads
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P o

Graphical Indicators for "Mumber15"

Indicator criteria For

% Nonsummary raws

™ Summary rows

v
™ Projeck surmmarsy
¥
Cut Row | Copy Row Paste Row | Insert Row | Delete Row |
is greater than or equal to A
Test For 'Mumber15' Waluels) Image 4
is greater than or equal ko §0.00 W Maove
is less than 0,00 o "
”

To display graphical indicators in place of actual daka values, specify the walue
range for each indicakor and the image to display, Tests are applied in the
order lisked and processing stops at the first successful best,

¥ Show data values in ToolTips

Help Import Indicator Crikeria, .. | Ik | Cancel |

% Work Progress (Text17) Formula: [Numberl7] & “%"

Critical Deviation (Number18) Formula: [Number17]-[% Complete]
Graphical Indicators:

L o

Graphical Indicators for "Mumber138” @

Indicator criteria For
% Monsummary rows

{ Summmary rows

[~
{” Project summary
7
Cut Row | Copy Row Paste Row | Insert Row | Delete Row |
is greater than or equal to A
Test for 'Mumber1a' Walueis) Image 4
is greater than or equal ko« §0.00 %a Move
is less than 0,00 &
-

To display graphical indicators in place of actual daka values, specify the walue
range for each indicator and the image to display, Tests are applied in the
arder lisked and processing stops ak the firsk successful tesk,

V¥ show data values in ToolTips

Help Import Indicator Criteria. .. | (0] 4 | Cancel

The bar chart contains the custom red work progress bar, which is defined as “from
Start to Finish7”, whereby
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Hidden column (Finish7)  Formula:
ProjDate Add([Start],[Duration]*[Number17]/100)

By using the Microsoft Project Organizer (menu Tasks > Organizer...) this sample view
together with “*Setup Time Reporting”, the associated tables with the same names
and the custom fields can be copied to your Global.mpt and from there to any
existing or new project.
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